keywords:
Bookmark and Share



Front Back
Redistribute into EIGRP (generic syntax)
redistribute protocol [process-id | as-number] [metric bw delay reliability load mtu] [match {internal | nssa-external | external 1 | external 2|] [tag tag-value] [route-map name]
Methods of Setting EIGRP Metrics when redistributin into EIGRP
  • Setting the default for all redistribute commands
  • Setting the component metrics applied to all routes redistributed by a single redistribute command
  • Setting different component metrics to different routes from a single route source
Setting the default EIGRP metrics for all redistribute commands
EIGRP subcommand:
default-metric bw delay reliability load mtu
Setting the EIGRP component metrics applied to all routes redistributed by a single redistribute command
parameters on redistribute command:
metric bw delay reliabiligy load mtu
Setting different component metrics to different routes from a single route source, when redistributing into EIGRP
use the route-map parameter on the redistribute command, matching routes and setting metric components
Redistribution into OSPF (generic syntax)
redistribute protocol [process-id | as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2 | nssa-external}] [tag tag-value] [route-map map-tag] [subnets]
Default metric when redistributing into OSPF, from
BGP:
another OSPF process:
All other sources:
BGP: 1
another OSPF source: take the source routes's metric
all other sources: 20
Seting the default metric for all OSPF redistribute commands:
ospf subcommand:
default-metric cost
Seting the metric when redistributing into OSPF, for one route source
parameters on redistribute command:
metric cost
Setting different component metrics to different routes from a single route source, when redistributing into OSPF
use the route-map parameter on the redistribute command, matching routes and setting metric components
Filtering of routes when redistributing
router config mode:
redistribute protocol [process-id | as-number]
[match {external | internal | nssa-external}]
[route-map map-name]

global config mode:
route-map map-name [permit | deny]
 [match
{interface interface-type interface-number |
ip address {ACL-num | ACL-name | prefix-list prefix-list-name} |
ip next-hop {ACL-number | ACL-name} |
ip route-source {ACL-number | ACL-name} |
metric metric-value [+- deviation] | route-type {internal | external [type-1 | type 2] | level-1 | level 2] |
tag tag-value}]

For routes not filtered by the route map, the route map can set other values using command:
route-map map-name permit
[match ....]
[set
{metric {metric-value | bw delay reliability loading mtu} |
metric-type {type-1 | type-2} |
tag
tag-value }
]

Route-map's match command options, that matter when using route maps for IGP redistribution

route-map map-name {permit | deny}
match ...
  • interface interface-type interface-num
  • ip address {[ACL-number | ACL-name] | prefix-list prefix-list-name
  • ip next-hop {ACL-number | ACL-name}
  • ip route-source {ACL-number | ACL-name}
  • metric metric-value [+- deviation]
  • route-type {internal | external [type-1 | type-2] | level-1 | level-2}
  • tag tag-value [...tag-value]
To filter redistributed routes with route maps, the route map needs to match the routes to be filtered with a route-map clause that has a
deny action

route-map map-name deny
Routes matched by route-map will not be filtered if they are matched by
parmit action

route-map map-name permit
1st potential solution to filter redistributed routes using route-map
  • Begin with a match of the routes to be filtered, using extended IP ACLs, with deny action so that routes are filtered
  • Then use a permit clause with no match command, matching and allowing through all remaining routes
2nd potential solution to filter redistributed routes using route-map
  • Begin with a match of the routes to be allowed, matching with prefix-lists, with a permit action
  • Then use the implicit deny all at the end of the route map to filter unwanted routes
how to use extended ACLs to match subnet and subnet-mask, when referenced by route-map?
example:
ip access-list extended match-101
permit ip host 172.16.101.0 host 255.255.255.0
Filter routes taken from ospf 2 process from being redistributed into eigrp 1, using distribute-list command
router eigrp 1
 distribute-list 1 out ospf 2

global config:
access-list 1 deny 172.16.4.0 0.0.0.255
access-list 1 permit any
Fields in the Type 5 LSA:
LSID(Link-State ID): The subnet number
Mask: The subnet mask
Advertising router: The Rid of the ASBR injecting the route
Metric: The metric set by the ASBR
External Metric Type: E1 or E2
Filter routes taken from eigrp 1 from being redistributed into ospf 2, using distribute-list command
router ospf 2
 distribute-list prefix prefix-list-name out eigrp 1
Setting AD (per Route Source) for RIP
router rip
 distance ad-value
setting AD (per Route Source) for EIGRP
router eigrp asn
 distance eigrp internal-ad external-ad
setting AD (per Route Source) for OSPF
router ospf process-id
distance ospf {external ad-value} {intra-area ad-value} {inter-area ad-value}
How to prevent Routing Domain Loops for two routing domains?
  • by setting purposefully high metric value when redistributing routes
  • by changing administrative distance
How to solve domain loop problems with more than two routing domains?
  • Using per-route AD Settings
  • Filtering on Subnets while redistributing
  • Filtering on Route Tag using Distribute lists
Command to set per-route AD
distance distance ip-adv-router wc-mask [acl-number | acl-name]
x of y cards